一个80后
程序员的笔记

[Centos]安装Vim

首先安装python2.7和python3

打开:https://www.vim.org/git.php

从Git下载vim8.0

yum install perl-ExtUtils-Embed perl-ExtUtils* libXt-devel gtk2-devel
git clone https://github.com/vim/vim.git

cd vim
#如果需要安装新版的话,直接查看git tag 但是如果要安装vj的话用8.0,8.1不支持
git checkout v8.0.1850
./configure --prefix=/usr/local/vim-8.0  -enable-multibyte --enable-fontset  --enable-xim --enable-gui=auto --enable-luainterp=dynamic --enable-pythoninterp --enable-python3interp --enable-rubyinterp=dynamic --enable-perlinterp --enable-cscope --enable-sniff --with-x --with-compiledby=erocpil --with-features=huge --with-python-config-dir=/usr/local/python2/lib/python2.7/config --with-python3-config-dir=/usr/local/python3/lib/python3.7/config-3.7m-x86_64-linux-gnu
make && sudo make install && sudo make distclean

ln -sf /usr/local/vim-8.0/ vim
ln -sf /usr/local/vim/bin/* /usr/bin/.

安装插件(本插件只适合vim8.0+python3.7.*)

git clone https://github.com/bbhsky/vimide.git
./update.sh
#安装插件
vim +BundleInstall +BundleClean! +qa
赞(0) 打赏
未经允许不得转载:FoolTiger笔记本 » [Centos]安装Vim
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏